Raster to Vector

MagicTracer Conversion Software
[ Documentation ] [ What’s New ]

What’s New in MagicTracer 2.0

Color Property Added To Vector Entities:

Vector entities can now be colored. An assortment of new tools are available to the user for applying and selecting colors.

Auto Smooth Hatch Boundary Command:

This option is available for DXF, EPS, and SVG output. With this option turned on, MagicTracer will automatically output hatch entities with smoother boundaries whenever possible. The Hatch entities will be smoother and easier to edit when the vector files are imported to other programs, such as Adobe Illustrator, AutoCAD, etc.

Note: This option should not be used when outputting DXF files for DesignCAD.

More File Formats Are Supported:

Note: Transparent backgrounds and layer options are not supported for PSD files.

New Options and Improvements to Vector File Output:

In addition to the original supported vector file formats (including DXF, DC2, XYZ, WMF), the following formats are added to expand MagicTracer’s usability:

While saving EPS, SVG, and EMF vector files, the curves will be converted to Bezier curves for greater compatibility with the applications like Adobe Illustrator, etc. For DXF vector file output, users will be able to choose the curve conversion type to suit their target applications. For example, they may choose to convert the curve to Bezier curves for AutoCAD. But if the target application is DesignCAD, the conversion is not necessary.

Bezier Curve Fitting Level is added to Save Vector File commands. Applies to DXF, EPS, SVG, and EMF formats for converting Lines and Spline curves to Bezier curves. Lower levels reduce points on the curves but makes curves less accurate.



DXF Output:
EPS Output:
SVG Output:
WMF Output:
EMF Output:
DC2 Output:
XYZ Output:

Clipboard Copy Now Supports EMF Format for MagicTracer Vector Data:

Supporting the EMF format, clipboard copy is much easier. Just paste the MagicTracer vector data from the clipboard to other applications.

Running Snap in Vector Mode:

Running Snap is added to the Vector Mode. Gravity, Nearest Line, and Midpoint Snap are supported in the Running Snap Mode. When the Running Snap is enabled, a box following the mouse cursor will be shown to indicate the snap point location. The Nearest Line and Midpoint snaps are mutually exclusive. To access the Running Snap, click the tiny triangle to the right of the vector select tool or use right-click popup menu.

Line Smoothing Command in Vector Mode:

Line Smoothing command is added to the Vector Commands for reducing the points on the lines and making them smoother. Control the smoothing results by adjusting the Range and Angle factors.

Connect Endpoints Command in Vector Mode:

Activating this command checks all the lines in the drawing or a selected region for endpoints that can be connected. Any points within the tolerance users specify will be brought together eliminating undesirable gaps.

Select Rotate Command in Vector Mode:

Select Rotate command is added to the Vector menu for rotating the selected entities. The Vector Rotate command uses 3 points to complete the command. Point 1 is used as the rotation center. Point 2 defines the reference point for the rotation. Point 3 is used as the new location of point 2. (Keyboard shortcut: R)

Select Scale Command in Vector Mode:

Select Scale command is added to the Vector menu for resizing the selected entities. The Vector Scale command uses 3 points to complete the command. Point 1 used as the scale center. Point 2 defines the reference point for the size and angle. Point 3 is used as the new location of point 2. (Keyboard shortcut: Ctrl+L)

Point Select Mode and Scale/Rotate Select Mode in Vector Mode:

Point Select and Scale/Rotate Select Modes are added to the Select menu in vector mode. Toggle the F7 key to switch between Point Select and Rotate/Scale Select modes. In Scale/Rotate mode, the Rotate and Scale commands are triggered by clicking the left mouse button in the vicinity of the control points. (Scale command is triggered by clicking within 7 pixels from a control point. Rotate command is triggered by clicking within 14 pixels from a control point.)

Select Move Command in Scale/Rotate Select Mode:

The Select Move command is triggered by clicking anywhere inside the selection box when the Scale/Rotate Select Mode is activated.

Save Image Command:

New Project Command:

New Project command now accepts canvas size in inches or image resolution (DPI).

Set Undo Levels Command:

Set Undo Levels command is added to the Edit Menu for changing the undo levels for raster and vector edit commands. (Previous versions of MagicTracer use 10 undo levels for both raster and vector data editing.)

Display Mode Dialog Command:

Display Mode dialog box is added to the commands that open the MagicTracer project files. The Display Mode dialog box can be switch off when the “Don’t ask me again” option is checked.

This new dialog box allows users to select the mode (image or vector) the project is opened in. The Display Mode dialog box can be toggled on and off from “Display Mode Dialog” command in the “View” menu.

AutoSave Command:

AutoSave command is added to Edit menu. When AutoSave is activated, MagicTracer will periodically save the project to the disk at user specified time interval with no user intervention.